Vidiot - Troubleshooting


#1

Hello ~

I received my Vidiot today, for the life of me I can’t figure out how to generate any visuals with it :upside_down_face:

I’m using NTSC, loop set to down, colorizer out to my display (C64 monitor). Cycling through the modulation presets doesn’t change or enable anything, nor does turning pots. I’ve tried patching as well without results. I did try the video input via a VCR but this will only display a faint version of the video. The colorizer and luma processor have no effect. I also receive a quick visual jump when switching between PAL and NTSC but nothing else.

Also worth mentioning I tried a different cable as well as a different television with the same results.

Anyone else ran into this issue? Is there a Hello World! Patch I should be doing. Am I truly a Vidiot!??


Vidiot - Getting Started
#2

What is the display currently showing? Is it black/no signal? Are you using the included power supply? Have you power cycled the unit after switching to the desired NTSC/PAL setting?

We are supposed to be doing an output test immediately before each unit goes into its box (in addition to more involved QC procedures earlier on), but it looks like a couple of DOA units have gone out. So if you feel like that’s the case please submit an RMA request on our website along with your return shipping address. We’ll send you a prepaid shipping label for return and a prompt return or replacement! Link here:
https://www.lzxindustries.net/support/ticket/submit


#3

I just opened mine, same issue.


#4

What is the display currently showing?

It’s black. My HDTV registers a signal coming through though.

Are you using the included power supply? Have you power cycled …

Yep using the included supply and did a few power cycles.

if you feel like that’s the case please submit an RMA request

Thanks Lars, I’m going to give it another go later tonight but I feel like this one might fall under the DOA category. I appreciate your insight.


#5

my wife had a couple little issues when I got mine a while ago lars got it sorted very quickly
I will try to post up a quick vidiot check type video


#6

Yes, sounds DOA. It could be something very simple, like the internal board-to-board cable has been installed in a reversed orientation (which would explain why it passed QC initially, but then probably skipped the output check after final assembly.) Send over the support ticket when you get a chance and we’ll get this sorted out ASAP.


#7

Same here :frowning: tested with a couple of PVMs with he same processes marked above, no signal. Tested a couple of other sources through the same cable and monitor intput and they come through fine. I’ll submit a ticket.


#8

I can now confirm that it looks like some units escaped with the internal cable flipped the other way around. If you are DIY handy and would rather disassemble and reassemble the unit to flip the cable around instead of going through the hassle of sending it back, you are authorized to do so without voiding your warranty. And of course we are happy to deal with it here if you attempt disassembly and decide you’re unconfident, or if you’d rather us just deal with it. Just providing you the option!!


#9

Whoa that worked! Is the ribbon cable itself assembled wrong? It doesn’t look like it should stick out towards the back panel.15386094898174846262915113018002|375x500


#10

The cables we’re using are just ones we have in stock for EuroRack module power cables, so yes – that’s as intended (it fits in the case just fine.) Rev1 had a much smaller connector that mated directly to the rear board and made assembly difficult (not to mention an expensive part) so this is a between batches update that makes things easier and more serviceable. That is, when someone remembers to plug it in the correct way!


#11

Thanks, I’ve closed it back up and spent all evening jamming with it. The footage available online don’t do it justice, there’s so much in there! You can close my ticket.


LZX Production Status 2018, Updated September 27th
#12

#13

You beat us to it! Here are some photos, too:


#14

I’ve spent the evening trying to get mine to work as well. First I thought it was a problem with the settings on my Intenstity Shuttle but now I’m noticing it actually captures something - black noise! Nothing happens when I turn the pots or flip the switches. The Intensity Shuttle itself works fine with my Critter ETC, so that’s not the problem. Do you think I got a unit with the incorrect cable orientation or am I doing something wrong?


#15

I opened it up and it turned out the cable was installed incorrectly. Fixed it and now it’s working.


#16

I’m very sorry for the waste of an evening, but super glad to hear you’ve got it up and running now.


#17

No worries! :slight_smile: Thanks!


#18

just receive my Vidiot and had to do the change, now it is working perfectly. I am glad I saw this thread.


#19

Glad you got it sorted out!! I should pin this post.