Memory Palace Firmware Update Guide

A new Memory Palace Firmware Update Guide has been posted below. This should explain the extra steps required to update from V18 to V19 clearly. Please comment below if you have any problems at all with the update process. If you already have V19 and are upgrading to a newer firmware, simply copy over the BIN file to Memory Palace and select “Update Firmware” in the System menu (then choosing the location of the new BIN file).


Hello ,

I followed the instructions on the pdf and my module still gets stuck in the SYSLOG loop.
No matter how many times I turn off and restart the module holding down the Boot MicroSD button on the back.

I am using a MacBook and read To use a app to clean the Mini SD card.
I have done that and it still does not work.

I noticed that my Memory Palace PCB is marked 2018. I don’t know if that has anything to do with it?
As on the instructions it says Upgrading from 2019 Production Units.

I have done all the procedures of taking the SD card out and loading the software on it. Also loading the firmware from the front USB port. I see it gets written on the card.

Might be best to send your unit back to us so we can see if there’s something else going on! It sounds like you’re doing everything correctly. Please send an e-mail to to arrange an RMA.

How to tell which firmware version I have?

Does it start up in the PARAMS menu? Do you have Ghost mode? If so, you have V19.


Yes and I have Ghost mode; thanks

Ive downloaded the upgrade onto my mac.
It didnt recognise MP through the USB connection so I was forced to take out the sd card and download it onto that.
I followed the instructions, deleted old files and loaded new files.
While placing the sd card back in the holder the metal flap dislodged. I was able to get it on again and the card is situated where it should be.
I followed instructions to update firmware:(Press the hollow square orange button)
It stalls for about 4minutes and then goes to the main screen, doesnt restart.
I navigate back to Update firmware and the menus contain undecipherable icons. Something is corrupted!?
I have a 2019 unit and I dont see any messages that internal memory must be initialised.
What can I do?

Could you include a photo of the weird icons you are seeing?

Ive reloaded the Sd card from the downloaded file. Is it supposed to look like this?

The funny characters dont appeat anymore but when I upload new firmware in the menu it stalls then shuts down for about 3minutes. The fan and lights on the back are still on though.
I took a video of it but this forim doesnt allow vids. Maybe put that up on fb community?
When it comes back on it doesnt go through the Memory Palace splash screen but goes straight to the menu.

I wish I could do the usb method, opening up the metal door on the sd card gives me anxiety, I fear Ive damaged it already, it doesnt click into place as well as it used to.

Did you run CleanMyDrive2 on the SD card after reformatting?
Did you power on the module while holding down “Boot from SD” and the red and yellow buttons (simultaneously)?

It seems reformatting and cleaning the drive was the guidance I needed. Its working now, thankyou.
Perhaps its obvious to do this but for me it would have helped to have this info in the update guide .pdf so I didnt need to waste your time.

Sorry about that. It isn’t always necessary, but seems to help some Mac users.

The clean my drive solved a bunch of issues for me as well.

i never got this new firmware working/ loaded .i just gave up on trying to update it.
As i am using a Apple and tried the clean my drive app and everything i could think of.

Mailing it to lzx just for a update during covid19 and the postal service being sketchy is a bad idea

You can send it in with FedEx or UPS

Is there a way to tell what firmware version one currently has in memory palace?

Could you share a photo of the System screen? The current V2.0.1 beta firmware will show the version on the system screen, but V19 does not.

I figured out I have V19 and will soon try V20. In any event, I was surprised to see that an earlier version is much easier to read…

Hi friends,

I have a 2018 Memory Palace, an early preorder unit. Attempted to update the firmware today on windows, via the USB port on the front. Followed the .pdf instructions, and am stuck in the SYSLOG loop, pressing and holding the Boot from SD button doesn’t seem to help.

Has anyone resolved this issue? Much appreesh.

Resolved the issue by holding the Boot from SD button, and the yellow and orange buttons, while having my significant other power on the case. Perhaps this could be added to the guide for us crustly old 2018 folks.

So I am still trying to update my old 2018 memory palace to the v.19 firmware. I keep getting stuck on the SYSLOG loop.

I tried you method of holding down - Boot Micro SD button ,Yellow and Orange buttons on startup.
I saw new screen saying updating “firmware will take a few moments” after that the module goes back into the same SYSLOG loop.

I don’t feel like sending my module to LZX due to slow shipping system of Covid.
And I really want to try out this new to me settings on the V.19 firmware.

How did you get past the SYSLOG loop?

please help.
I feel like smashing this module with a bat everytime I see that SYSLOG message