Memory Palace - sd card failure & other issues :[

hi guys,

got a memory palace lately. it’s was a display unit and seems to had some nasty wigglers on it

sorry if these problems have already been solved somewhere else, couldn’t find it

first of all it runs on version 2.0.1

1st problem:

  • SD card is not found
    tried to format it and use some others, but without success
  • tried to enter via usb-port, which gives me access to the device folders /jsn with media.jsn & system.jsn
  • tried to install a recent firmware but the device crashes at boot time
  • also cleaned the SD slot :[
    visibly the device seems to be in good condition

Google Photos

2nd problem
the faders seem to be out of calibration and wiggle by themselves slightly

  • is there any way to recalibrate them? :B

Google Photos
Google Photos

Thank you very much for your tips and advice


KaltwaßerTV - Leo

1 Like

Sorry the MemPal is giving you trouble. What are the specifications of the SD card(s) you are using?
You can recalibrate the sliders by selecting Restore Defaults in the System menu. If they are still misbehaving after default restore, please send a message to to arrange for repair.


My unit has that same slider behavior when loading default settings. It appears that the SOFTNESS slider has S Curve setting on Heavy that causes it to sit at 73.48%. Changing the S Curve to Off puts it at 50% (centered)

Regarding the my AUX slider, the bottom half of slider is a dead zone. Only the top half of slider changes the value. Not sure if this is intended behavior. Hitting the Yellow button on value screen causes the unit to hard lock too.

For what its worth, this is serial #35 Memory Palace purchased new from pre order has been used lightly and stored carefully over the years.

1 Like

These are definitely firmware issues. The AUX slider bug is on our list of issues to fix in the next firmware. Apologies for the issues–we’re excited to dig back into Memory Palace, leading up to its reintroduction.



also very looking forward to it, but it’s painful that we have to wait for mk2 dev to start up for these fixes on something released so long ago. of course I’m understanding and sympathize with all the set backs that have happened, wishing a firmware engineer happens soon :smiling_face_with_three_hearts: :vulcan_salute:


Right there with you. We’ll get there. All the TBC2 development time will make MemPal upgrades so much easier.

1 Like

yeha, thanks for all the replies. so seems the slider issue is fw based. the softness slider is from time to time completely locked, a “restore defaults” unlocks it again but with the implied misbehavior. @Entropist S-curve to Off fixes this indeed. The AUX value lock i can also confirm.

my main problem is still the unfindable sc card :slight_smile:

SD cards i tried:

San Disk edge 8gb hc1
san disk ultra 16gb hc1 (10) A1
san disk extreme 32gb v30 hc1 (3)A1
Toshiba 64gb xc1
toshiba 8gb hc1 (4)
netac 8gb hc (6)

1 Like

In that case, it sounds like a broken SD card slot.


Its at my dealers place now for repair. Looking forward to finally integrate it to my system. Tbc2 is about to arrive too, hehe.