Memory palace ghost media

Hi there-

I’ve been using the RGB inputs for a while and neglected the media loader.
Returning to the media loader I’ve found that several folders of images no longer work.
Moreover, they no longer appear on the card.
I’ve tried to remove (in the hopes of later replacing) the media, but with no luck.
I’ve formatted the card, refreshed the firmware, and reset to defaults.
However, the references to the ‘ghost’ media remain.
Any suggestions?

Is it possible that you placed image folders on MemPal’s internal drive?
Have you tried resetting MemPals defaults and firmware, using the System menu?

I had this happen once too after deleting and adding new media via USB using Window 10, all the deleted folders and images still showed up on the MP menus even though the card showed them gone via USB connection. But in my case, power cycling the MP made the deleted media fully disappear.

Does resetting the defaults or firmware replace the original NTSC images on the card?
I’d got rid of them for PAL versions but they seem to have come back.

Could you try resetting the defaults and/or firmware, to see if it helps?
Also, it would be worth checking both the internal drive and MicroSD card to make sure files have been removed from both.