The Memory Palace Experience (Unf#$&ing El Palacio de la Memoria)

As consummate and intentional novices with every step we take, we here at 48HourVideo like to go about new experiences as though we’re children.

In that vein, please find enclosed in this candlelight-penned letter the issues and solutions we’ve experienced con la Memoria Palacio:

  • Problem #1: When using “BOOT FROM SD”, MemPal screen shows startup splash and firmware version, but nothing more.
    • Solution: Set rear panel switch to Internal Sync while using BOOT FROM SD feature to verify boot. (Or connect valid sync with External Sync enabled).

The videomancer @kemble-48HV with the aid of his party mates clutches the nearest sync cable while meditating on a massive metaphysical 20sided die. ‘Sync applied?’ Is heard faintly in the distance as the d20 explodes into powerful and beautiful luz de Memory Palacio.

  • Problem #2: Windows file transfer error using front-panel USB connection, resulting in a frozen MemPal interface, stuck on the USB interface screen. On system restart, MemPal screen shows startup splash and firmware version, but nothing more.
    • Solution #1: Hold rear panel “BOOT FROM SD” button while powering on the device, with device in Internal Sync mode. If that doesn’t fix the problem, remove SD card from system, reformat as FAT32 on a computer, copy latest firmware. Return card to MemPal, hold rear panel “BOOT FROM SD” button while powering on the device, with device in Internal Sync mode.
    • Solution #2: Verify that there are no hidden files on the SD card. Delete if found. Suggested to use 'Clean My Drive 2’ on OSX.


  • Problem #3: XY VC inputs are producing unexpected results.
    • Solution: Cycle the CV Scale option on Page 2 to return normal XY function. Will need reapply at every Memory Palace startup/power cycle.


  • Problem #4: VC inputs do not respond to incoming signals.
    • Solution: Power cycle the Memory Palace.


  • Problem #5: Still image in Memory Palace gains artifacts (on our system, thin blue horizontal lines) when an external media player (connected via Visual Cortex decoder) is power cycled. Possibly through Sync?
    • Solution: Power cycle the Eurorack case while leaving the external media player on.

I’ve encountered problem #2 a few times. The last time it happened, I took the SD card out, loaded in Windows, enabled ‘Show Hidden Files’ and noticed that a .DS_Store file made it’s way over because I was copying a folder over my home network from my Mac. I removed this file and it booted fine.

Perhaps the LZX team can add some code to ignore these hidden files in a future firmware update :slight_smile:


Thanks for the contribution @bsarps , I added it into the solution list on the main post! :beers:


We’ve got some “ignore Mac crap” code in there already, but apparently it is still causing some issues. I’ll see if we can get to the bottom of it! Thank you.


Re problem #2 - I always use a program to delete hidden Mac files before loading - best results for me are with the nagware ‘Clean My Drive 2’ on OSX.


Hi, I just received mine, I want to report a strange issue : plugged to power board, double check everything, and … nothing, no screen, no white led light on back pannel… I began to turn white as a sheet. tripple check every thing (other modules worked well). After some breathes I try to “choke” it with 12vdc optionnal plug : fan run, white led, and full boot…
I also clean sd card.
Then I unplugged my external power supply, and restart my case PSU… now everything’s well… Lars, do you know what’s happened…?


Im unable to change the NTSC/PAL mode when using my Memory Palace as master.

When it boots, its by default in NTSC and the menu to change that is disabled, is there a special button combination to change the value to PAL? I have rev18.


We’re having some trouble with Memory Palace that we can’t fix. It displayed all the characteristics listed below initially, and continues to display them after an SD card reformat and copy over of current, default firmware with no amendments. The module has approximately 40 hours used time. It’s been largely stable other than some horizontal artifacts in certain warp-mode based patches.

Today, on initial startup, Memory Palace no longer responds to slider input. The values for the sliders shown in the display are capped at maximum despite slider position. The device outputs a signal that looks full white on Liquid TV and Visual Cortex, and full black from the Memory Palace’s previously functioning Composite2 Output. Neither output responds to slider motion or key presses.

Menu pages can be navigated and settings changed, but the output and slider value/responsiveness remains the same.

We’ve tried numerous sync cables and configurations (external/internal). We’ve tried multiple composite video and TS patch cables that work with other equipment.


If there is enough interest, I propose some sort of crowd sourced effort to establish a functioning user manual that can serve as a fear, uncertainty, doubt offset when these unpredictable situations arise. Certainly I can’t be the only one eager to stabilize the memory palace within an industrious work flow. Documentation can start somewhere. Perhaps the community members who rely on this tool in a performance or production modality would be interested in this collaboration, as any amount of uncertainty of use in those cases could be quite a handicap.


The user manual is here, @7pip and the rest of the community are welcome to edit and build upon what is there:

@luix It sounds like you have Memory Palace in external sync mode. You can only select the NTSC/PAL format in internal sync mode. In external sync mode, Memory Palace will detect the sync format from the external source (patched to sync input on the rear.)

@gaeljaton Not sure. Which model power supply are you currently using and what is the total current load on it?


To be clear: Memory Palace should not be stalling, crashing, or failing to boot. We’ve had our units here in the lab running mostly 24/7 for weeks without crashing. If you’re experiencing any kind of instability that’s not fixed (in a permanent way) by the tips suggested in the OP, please e-mail to request an RMA.


2A @12v
2A @-12v
(4A @ 5v)
I think it’s enough. I guess it was some kind of varnish on ext power plug which doesn’t allowed 12v bypass, plugging connector should have cleaned the contact.
As mentionned, now it boot well and all effects seem’s to work as desired.
I just remain an issue on DVI-D out, sometime it stop working after few minutes and back again when just reboot (without touching cable). And the dvi - hdmi converter provided just don’t work (I got an other one which work - at least few minutes)


Exactly, what Im saying is that when I put the sync switch on INTERNAL, I cannot select PAL on the menu its still disabled (grey) regarless of the switch. I’ll wait for the v19 and see if that fixes the problem.

The auto detection (when external is activated) is not working well, and neither the switch internal/external. I want to be able to select PAL/NTSC manual anyway always if is possible.

1 Like

@luix What is your sync source that it’s having trouble detecting as NTSC or PAL? Is this with Visual Cortex? We had one report so far where the switch was actually broken, does it look damaged at all?

1 Like

My sync source is Visual Cortex with decode switch off (to use internal sync of VC). MY VC boots nicely every single time in PAL, Im syncing it using the SyncOut of VC into the SyncIn of the MP with the terminate ON.

Switch and soldering looks good. I’ll just wait for v19 and see what happens, thanks Lars.


Having issues getting hdmi out working. Tried both an intensity extreme and ultrastudio 4K. Any specific setttings i need to get it to register?

I haven’t tried with either of those devices, but anything with 480p/576p support should be working. Have you tried on a display yet? If you have another adapter or cable to try, it’s good to rule those out as potential problems as well. If all fails, get with us to arrange an RMA.

all my system draw :
1.1A @+12V
0.5A @-12V
and 0.15A @+5V
I’ll investigate with bad solders and try to re-upload firmware…

1 Like

I did a gig last night, everything worked well for several hours. I choose to believe it was a kind of break-in phase. a time to know each other in a sens… :wink: (or damned varnish again…?)


I have the same problem, can’t switch from NTSC to PAL in internal sync mode. Format is greyed out/disabled and can’t be selected.

Running in external sync mode, MP doesn’t seem to want to switch to PAL. I’ve tried with a Vidiot in both NTSC and PAL. Vidiot colorizer out to MP sync in works for NTSC only.
If I run the Vidiot in PAL, the MP seems to stay in NTSC and the MP’s output image displays black and white scrolling typical of format mismatch.

1 Like