Suggestion for memory palace firmware

Hi guys, first of all thanks for creating the memory palace, I have two and they are not enough.

I created this tread for possible suggestions for future implementations on the module sw.

I’ll start with this:
is it possible to implement a menu selection for the folder because it takes a long time to load them all one by one if you want to switch to another specific one?


Yes, the upcoming Memory Palace firmware will include a menu for image folder browsing. One of many improvements coming from the epic TBC2 firmware push.


Thank you!
Another question, it’s normal that with painting mode and directory with less than 64 frame and size<8mb sometime freeze and have some strange glitch? It’s because i use png?

1 Like

Which firmware are you using? The upcoming firmware should be glitch-free.


I have fresh new memory with 2.0.1

I can’t wait for the new firmware

1 Like

there is a max tot folders size? If i charge to much file it dosen’t start, raming blocking on charge screen

80 MB 32 folder

will this also be a push for diver?

1 Like

From the Memory Palace User Guide:


Diver will receive new firmware at some point in the future.


This is the problem, i have 24 folder and no one is up to 64 images or with 2mb filesize

and on power-on it stuck here

i can provide the folders if ithey serve to replicate the bug

I don’t believe it has anything to do with the files. What is your sync source and routing?

1 Like

visual cortex —> memory palace (in photo) ----> second memory palace

I tried even with no external sync but same error

I delete one folder and then it work…

Aha. If it works when you delete one folder, then you should proceed with that method until the next firmware is available. Do both Memory Palaces behave identically if you load them with the same media?

1 Like

Yes they acting identical, thanx i ll wait the next firmware!

I suggest that mp should have a less noisy cooling fan.


Awesome about folders. Swapping folders during a live set is a real slow down, especially if you miss the one you want and have to go through them all again. Excited for a better system. :yum::+1:


Yea me to!! I can’t wait to see the other upgrade to the system

Ok, why my memory can’t start with this set…

I can’t figure out

Maybe it’s a sync issue. My MP usually gets stuck on that screen when there is an issue in the sync chain. If your MP is at the end of the sync chain, then maybe check to see if the termination button is engaged.

Found the problem!

In V2.0.1 there is a limit to 1024 files.