Cadet Sync Generator Problem

Hello,
I know LZX does not offer any help with the DIY projects but i figure i might as well ask for some help.
So i built the Cadet sync generator but for some reason i feel the atmega chip might not be programmed.

I connected the h and v outs to a oscope and seem to not get any 1 volt pulses.

I have it connected to the Cadet RGB encoder with the 14 pin sync cable.
I also have looked over the board for any missed solder connections.

any help would be great!

1 Like

can you try posting hires pics so we can see IC/diodes orientation, and we can do quick solder inspection?

my testing procedure is always is

  1. if you have a bipolar power supply with ampmeter try see how much current your module is pulling, most of the time will be a short or bad orientation component the problem

  2. if the pcb has microcontroller, try testing if it has the requiered power supply, in this case 5v.

  3. check if anything gets too hot, you can do this by gently touching components (you can do this because its a lopower application) or use IP Alcohol.

  4. check for bended legs of ICs

  5. check for cold solder joints

thats at least a starter, its possible that everything is fine and as you said its just the microcontroller but we cant help if we dont get more details or info on your build

hello i have included some pictures.

image

you have to connect r13! use a small wire or snipped off piece of a resistor leg.

note: in the future, use IC sockets.

Thank you! i will connect it and see if it works out. i will post back with the results.

As for the ic sockets i think i remember something that they would not recommend the ic sockets due to noise interference or something like that?

I thought that was only with the modules that use the TL1251, like the Fader

so the bridge wire on R13 made it come alive!

thanks for eagle eye and help.

it never hurts to help, like Spongebob says

I think Lars recommends not using sockets with all the Cadet (and Castle?) stuff because the sockets can add a small bit of capacitance to these higher-frequency-than-audio-rate circuits. That said, I’ve used sockets on some of the builds and haven’t noticed much issues.

I’ve got some type of issue with my sync generator that’s causing it to fail to genlock. Everything else about the sync generator seems to work - I’m able to sync the ramp generator and RGB encoder over the sync bus as well as some Castle clock VCOs over the power bus, the 1V outputs work, and it’s buffering the RCA input to the RCA output fine.

The patch I’m working with is:

  • Vidiot RCA luma output -> Cadet I input
  • Vidiot 1V luma output -> Cadet II Red input
  • To confirm that the sync bus is working, I’m also patching the horizontal ramp from Cadet IV to the Cadet II Green input.
  • Cadet II video output -> display

The behavior I’m seeing is:

  • The pattern from the Vidiot luma processor scrolls left to right, with a black gap every so often for the horizontal blanking interval.
  • On an oscilloscope, I can see the separated sync from the video input arriving at the SIG_IN input (pin 14) and the generated sync from the ATMega arriving at the COMP_IN input (pin 3) of the 74HC4046AE PLL.
  • I can measure 5V at the Vcc pins of all the 5V ICs.
  • At the PH_COMP2_OUT pin of the PLL, I measure 0V.
  • At the VC input pin of the crystal oscillator, I measure 0V.

Maybe I’ve just got a dead PLL? Makes using sockets in the future sound real appealing. Here are some photos, any thoughts or advice are tremendously appreciated.

so you are syncing the sync generator with the vidiot?

what happens if you leave out the vidiot and only use the sync generator + ramps?

Yeah, with just the ramps on the sync bus patched to the RGB encoder the sync is fine, no “marching”. I also just discovered that if I patch:

  • CCTV camera -> Cadet I input
  • Cadet I output -> Cadet III video input
  • Cadet III luma -> Cadet II Red in

as described in the Cadet I manual, it syncs to the camera! But replacing the CCTV camera with the Vidiot luma out, the image is still marching. Same if I connect Vidiot sync out -> Cadet I sync in and patch an oscillator from the Vidiot to the RGB encoder. Based on this post I was expecting these to work. However I can patch:

  • CCTV camera -> Vidiot camera input
  • Vidiot sync out -> Cadet I sync in
  • Cadet I sync out -> Cadet III video in
  • Vidiot luma out -> Prismatic Ray

and now everything in my rig is synced! However, disconnecting the camera input from the Vidiot makes the Vidiot and Prismatic Ray oscillators start marching again, so I guess that’s the most important thing, at least with my unit. The sync loop thru switch on the Vidiot hasn’t seemed to make a difference for any of the above scenarios.

Just built a Cadet Sync Generator, and having some issues.There’s no signal at all from the horizontal, vertical, and frame sync outputs on the front panel. I’m also seeing +5V on every pin of the sync bus (aside from GND). I was pretty careful with the build, and can’t see any obvious issues, but maybe I’m missing something. The 5V regulator is doing its job, and I measured +5V on the Vcc for all the chips, and a +22.5V difference across V+ and V- on the LM6172’s.

Here’s what I’m seeing out of the ATMEGA88A (received from LZX and presumably programmed)

Pin
1 5V
2 5V
3 0.744V
4 0
5 0.690V
6 0
7 5V
8 GND
9 2.556V
10 0
11 0.682V
12 0
13 0
14 0.685V

15 0
16 0.564V
17 0.612V
18 0.618V
19 0.619V
20 5V
21 0.574V
22 0
23 0
24 0.555V
25 0.555V
26 0.556V
27 0.555V
28 0.574V

Appreciate any advice or troubleshooting ideas. Thx!

Does anyone know what the output voltages would look like if the ATMEGA88A wasn’t programmed?

I am in a similar position to the above posters with my newly finished Sync Gen build - I am not seeing any sync outputs, just 5V DC on every relevant output pin of the ATMega.

My build is pretty clean (photos attached). R13 is soldered as a wire link. I see a clean 5V from the regulator, appropriate inputs and outputs on the LM1881 and 4538 pins, the 4046 is seeing the right input and the crystal seems to be generating an appropriate clock (admittedly measured with an old low bandwidth CRO so detail isn’t great at those frequencies).

It may be worth noting that I didn’t have a 74HC4046 to hand so I have tried with various other CD4046, MC14046, HEF4046 and HCF4046 instead, and they all showed the same behaviour (i.e. no output on the ATMega pins).

It seems to be a common question above, so “is it possible I have a blank ATMega chip?” Or do I need to use the specific 74HC4046 part rather than similar subs?

Thanks,
A.

IMG_3762 IMG_3763

Sounds like you have a blank Atmega chip. You can either load the firmware yourself (that’s what the 6-pin header on the PCB is for), send it to us to program it for you, or we can send you a burned chip. We had one batch escape earlier last year that had a few blank Atmegas in it.

1 Like

Mine is still sitting on my bench–maybe it was one of the batch with the blank ATMEGA chips? It would be helpful if I could ship it to LZX to be programmed. Thanks.

Cool, just send in a support ticket to support@lzxindustries.net

1 Like

Thanks Lars! I’ve splurged on a $4 ATMEGA88 USB programmer :slight_smile:

1 Like

Hi,

Troubleshooting my Cadet sync and after checking everything I’m pretty sure the firmware wasn’t loaded on my ATMEGA.

Have grabbed the firmware off github and I’ve tried programming it but getting the following error. Just wondering if I’m doing something wrong.

avrdude -c avrisp2 -p m88 -P com2 -e -U flash:w:LZX-C1-SW-V1.0.elf

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.06s

avrdude: Device signature = 0x1e930a
avrdude: erasing chip
avrdude: reading input file “LZX-C1-SW-V1.0.elf”
avrdude: input file LZX-C1-SW-V1.0.elf auto detected as invalid format
avrdude: invalid input file format: -1
avrdude: write to file ‘LZX-C1-SW-V1.0.elf’ failed

avrdude: safemode: Fuses OK

avrdude done. Thank you.