Can't Get External Video Sync with Cadets

Hello, I posted about this is another thread about using a camera with cadets, not realizing that that thread was in the helpdesk section and not the DIY section, so I’m reposting my issue here (mods: sorry if that’s annoying).

The problem is that when I put an external source into Cadet I → Cadet III → Cadet II, the inputted video constantly scrolls to the left. I thought this was an issue with my NTSC camera, but the behaviour is the same with other sources.

The behaviour is also the same if I go directly into the Video Input, skipping the Sync Generator. My consequent hypothesis is that the problem is with the Video Input, particularly since the Sync Gen is doing it’s job otherwise. But I’m not sure where to look and I’ve reflown all the joints. I’m worried I may have ESD-ed the LM1881.

Something I haven’t done yet is to check voltages on the LM1881 when it is running, because doing so will be tricky with my setup. But I suppose that’s my next step.

Anyhow if any of your smarty-pants know what might cause this type of malfunction, I’d be grateful for any insight. I’m hopeful it’s not the LM1881 since it seems they are no longer available unless you’re buying hundreds of them.

Here’s some images of the Sync Generator and Video Input boards.




EDIT:

The LM1881 on the Cadet III is getting 4.75V on Pin 8, 4.35V on Pin 1, and 4.38V on Pin 5.

Could it be that getting 0.25V short of the 5V minimum Vcc is causing trouble?

There are a few helpful threads in the DIY section that might be worth a read, e.g. Cadet Sync Generator Problem

You can’t really use the encoder usefully without a sync gen/sync extractor. Probably the sync gen is generating internal clock that isn’t synced to the video input at all, hence the scrolling.

1 Like

Can you show us how you have the modules patched up?

1 Like

Yeah, this is why I was thinking that the problem is with the Video Input, since I’ve been using the Cadet system for over a year and I have Sync for my oscillators and whatnot, it’s only with trying to bring in external video that I have problems. My next move though is to go over the Video/Sync In section of the Sync Gen.

If I understand you, the suggestion is that perhaps it is the circuity around the LM1881 on the Sync Generator that might be my issue?

Thanks for the link, I’ll go over that thread. In the meantime I have ordered some LM1881 clones that Fox had mentioned in another thread as a viable stand-in, worst case Ontario I’ll see if replacing one or both of those chips ameliorates things.

@creatorlars

Sure, here’s how it’s patched:

So the Yellow RCA is the Composite Out from my camera, the White-stripe RCA is going Cadet I Out to Cadet III In, Luma Out from III to the encoder. While I have your attention, I love your work thanks so much for releasing these designs!

Sounds like a genlock issue – the LM1881, the VCXO, 4046 and 4538 parts of the Sync Gen. Make sure you’re seeing something coming out of the LM1881 pins when you have a source attached if you have a scope.

Also maybe try patching the camera to the C3 input first, then thru to the sync gen.

2 Likes

Thanks @creatorlars, that was very helpful. I’m starting to get a (very) vague understanding of what’s going on with the schematic now.

Unfortunately patching into C3 first produced the same results.

I do have a scope, but it’s a big ol analog one that I’m not super experienced with. Here are the results of my investigations on the Cadet I, measuring voltages with MM and description of appearance on scope

LM1881:
Pin 1(SyncOut): 2.7V, appears on scope as two parallel lines
Pin 2(Input): waveform of some description, reads ~2V on MM but looks to be about 0.8V on my scope
Pin 3(VertSyncOut): 5V, appears as a solid line at 5V and a dotted line at 0V
Pin 4(Gnd): 0V
Pin 5 (Burst): 4.65V parallel lines again
Pin 6 (Rset): 1.23V, solid line
Pin 7(OddEvenOut): 2.5V square wave
Pin 8 (Vcc): 5V

4046
Pin 3 (CompIn): 5V parallel lines again (what does that mean?)
Pin 13(PhComp2Out): 0V ← I think this might be my problem
Pin 14(SigIn): 1.49V, solid line
Pin 16(Vcc): 5V

4538-1
Pin 2(Cext/Rext1): 0V
Pin 4(A1): 1.47V line
Pin 5 (B1): 2.9V parallel lines
Pin 6(Q1): 1.47V line
4538-2
Pin 11 (B2): 0V
Pin 12(A2): 0V
Pin 14(Cext/Rext2) 1.47V, line

VCXO
Pin 1(Vc) 0V
Pin 3(Gnd): 0v
Pin 4(Out): ~+/-2.5V waveform
Pin 6(Vdd): 5V

So it seems to me that the LM1881 may be okay, but that the Phase Comparator output on the 4046 is not sending a signal to the VCXO. Which I guess means that I have the internal sync clock, which is why my system has been working fine otherwise, but can’t clock the VCXO to the sync generated by the LM1881.

I’ve checked if there is perhaps a short to ground from 4046 pin 13, but no dice. Going to check continuity and poke around between the 4046 and the VCXO.

Great job! That seems like the right direction for a diagnosis. Can you verify that the 4046 IC is the exact same part listed on the Cadet I BOM? Some variations of 4046 do behave/perform differently.

Can you snap a photo or screenshot of your scope when probing Pin 3 and Pin 13 of the 4046? Make sure time constants and voltage scale are visible in the shot. If your scope has a front USB it may be able to save screenshots to a USB drive.

1 Like

It is a CD74HC4046AE, so I believe it is an exact match.

My scope is a Tek 2235 so it’s never even heard of USB.

You caused me to discover the seconds/divison knob, I’ve always just had it set to 1ms. Playing around with that is pretty fun though damn, I can really see these waveforms when I set it into the microseconds.

Anyhow here are the pictures:


This is Pin 3, each square on that screen is set to 2.5V so that upper line is at about 5V. This is 1ms.

This is 20 micro seconds

And 1 micro second. That’s so cool, I didn’t get why it was two parallel lines but now it makes more sense, thanks for accidentally teaching me about the importance of the time constant.

And here is mysterious Pin 13. Reads 0V on the MM, just seems to be dead on the scope, doesn’t do anything fun when I change the timing.

EDIT: holy shit now I understand how to see low-frequency signals on my scope, too. Thank you Lars, lol. The time knob rules.

2 Likes

Yay for temporal constants!

On the measurement where Pin 13 reads 0, do you have an external video signal plugged into the front sync input of the module and active? If not, try that. If so, swap that IC for a fresh one.

1 Like

Yes I do, I’ve tried it both Video → C1 → C3 and the Video → C3 → C1 method you mentioned earlier.

Okay well this is an excellent lead. Thanks so much for your help, I really wasn’t expecting to get such guidance from the maestro. I will report back when the chip has been swapped.

So the good news is I was able to desolder the 4046 without any trouble, recently got some helping hands and they sure do help with the desoldering pump.

The bad news is that even with a fresh chip I’m getting the exact same behaviour, and there’s still nothing happening at pin 13 of the new 4046. :frowning_face:

I’ve checked continuity across the voltage divider (I think) circuit between the 4046 and the crystal… Seems fine there. I have some LM1881 clones coming from China so I guess when I get those I’ll try replacing the LM1881 simply cause I have no idea what else to do.

Do you see something coming out of the CSYNC pin on the LM1881?

1 Like

Hrmmm yes, which I suppose means the 1881 is functioning.

The 4046 has a signal on the Sig In, a signal on the Comp In, C1A and C1B are connected by the 47p capacitor…I’ve got 5V on Vcc… But nothing coming out on pin 13…

I’ve checked for shorts between the pins. I’ve checked for short to ground on pin 13… Got 5V on the Inhibit pin…

No comprende.

EDIT: looking at pin 13 with multimeter, it is reading 3.3mV. Which I don’t think it was before I replaced it. I… guess that’s progress?

On Pin 14 Sig In of the 4046, I’m just getting a steady 1.47V DC – is that expected?

Sorry for my rather immature response but you guys are so damn smart. I wish I could explain and brainstorm my problems at this level. My mind is more akin to the first ameba trying to make fire by rubbing water droplets together :pensive::crazy_face:

1 Like

Me smart? Me just learned how to use me oscilloscope as a side-effect of Lars’s advice, who is indeed very smart.

But if it looks at all like I know what I’m talking about, it’s really just because I have run into enough problems with things I’ve tried to build that I have gradually built up a teensy bit of information, the most important of which being knowing to look at datasheets. I don’t know how these things work but at least I can see what’s supposed to be an in and what’s an out.

Anyways, to those it may concern, I fixed the fucking thing. Turns out the problem was with the 4538, and not with the 4046. Don’t know why or how, but I replaced that chip as I had no idea what else to do, and now it works. One thing I noticed is that the old 4538 was just labeled 74HC4538, while the new one is 74HC4538E, but I think that’s just a reference to the packaging and that I probably ESD’d it or overheated it or something.

So good day for me, and doubly so since I just got back from a road trip and have all these images and footage of forests and shit that can now be synthesised.

Anyways, thanks to @rempesm, @VisibleSignals and @creatorlars for helping me along the way.

3 Likes