Blackmagic Intensity Extreme and Adobe Premiere

Hi y’all,

I was asked by a friend to do some VHS tape digitization of a buuunch of home movies. My ideal solution to do this would be using my BlackMagic Intensity Extreme (Not Shuttle, though they are very similar I’m sure) to capture straight into Adobe Premiere CC 2019 on my Macbook Pro via my VCR’s HDMI out to the Intensity Extreme’s HDMI in. For some reason, I absolutely cannot get the Blackmagic device to display a signal in Premiere’s capture window. I have gone into the playback settings, set the video and audio devices to BlackMagic Intensity Extreme (the software actually detects it just fine), tried adjusting the capture formats to both DV and HDV, tried toggling “Device Control” on and off, which I’ve read isn’t used by all capture hardware, but some requires it to be detected by Premiere. I have even tried switching to component, but that still doesn’t do anything. No matter what, when I’m actually in the capture window, it just acts like there is no device connected, even though it is being detected in the “video devices” under playback settings, which makes me think that all the plugins should be installed correctly.

I am at a total loss. Currently I am stuck using my backup capture device, a Grass Valley Canopus ADVC-110, but that only has S-Video and composite I/O, and the quality is noticeably worse. I really want to figure out how to use my preferred method because I want these transfers to look good. They are extremely sentimental to my friend and likely the only time they will ever be transferred. Using BM Media Express is out of the question. The files it makes are gigantic, and after capturing for more than 10 minutes, I get random frame drops very frequently, making the footage unwatchable. I just captured an entire 3 hours of footage straight into Adobe Premiere via my ADVC-110 with no dropped frames, I really want to say that the culprit is Media Express and it is so endlessly frustrating that it’s the only thing I can get the Blackmagic Hardware to actually work with. Has anyone had any luck figuring this issue out? Surely I’m not the only one.

My setup:
2013 Macbook Pro running High Sierra 10.13.6
2.6 GHz Intel Core i5
8 GB 1600 MHz DDR3

Black Magic Intensity Extreme (2011?) Thunderbolt version

Adobe Premiere 2019 CC

Blackmagic Desktop Video 11.5 (latest version as of Feb 2020)

Grass Valley Canopus ADVC-110

also, any general tips about VHS digitization in Premiere would be helpful. Always love hearing different approaches to something like this. Probably a lot of obvious things to most that I’m unaware of. I want all of the resulting files (one per tape) to be 720p. My VCR has output options for 480i all the way up to 1080p, so ideally I could output 720p directly to the HDMI in on the Blackmagic device, but with my ADVC-110, that entire process has to be done within Premiere, which adds a lot more steps + confusion.

but isn’t VHS in PAL / NTSC format? Or does your VCR have an upscaler built in?

It’s a DVD/VCR combo that shares all of its outputs. The upscaler is very decent

You could try OBS? It’s a free video streaming solution, in my experience it detects BM hardware flawlessly and can record long sessions with a pretty good quality/file size ratio, I think the output files are MKV.

2 Likes

Can anyone using Adobe Premiere CC 2019 and a Blackmagic Device confirm where the Blackmagic plugins are supposed to go? I don’t even see an option in the capture window for BlackMagic capture, so my hunch is that the plugins aren’t installed correctly.

If anyone has the same issue and is curious, I have managed to get a video feed to Premiere. I had to download an old version of Blackmagic Desktop Video and the “Blackmagic Capture” instantly showed up. Once I build my new PC, I might come back to this and re-update the Blackmagic software and see if it was just a case of the plugins being installed in the wrong place or if my specific product “Intensity Extreme” stopped being supported after a particular revision.

I had issues with my BM Shuttle Thunderbolt when Apple updated the MacBook OS. I found the new firmware update on the BM site and after updating it still would not work. I found out that you have to remove all the old drivers from your computer, the update will not do it for you. Once I cleaned that up and reinstalled the Desktop Video Setup up it worked fine. That was with Premier 2019. It looks like they have a new version that works with Premier 2020, but I have not tried it.

I discovered that for some reason the newer versions of the BMD software were putting all of their plugins in the wrong folder, so I just moved those to where the old one was putting them. I’ll have to double check the exact file path.

Definitely sloppy, but it works great when you get it dialed in! I noticed that they now have an update for premiere pro 2020.

2019 is more stable for me than 2020 at the moment. I tried updating, but 2020 would fairly consistently crash in the middle of a capture for me. Not sure what the deal is, seems like that kind of thing always happens with new versions of Adobe products out of the gate. Had similar stuff happen with Media Encoder for seemingly no reason at all. Really makes me hate The Cloud even more. At least it’s easy to roll back.

It appears that this issue was pretty specific to my mix of old, no-longer-supported capture hardware and newer software, because my PCIe-based Decklink Mini Recorder (not the 4k model, but the older, still supported 1080p one) worked out of the box with Premiere 2020. When I rolled back to Premiere 2019, still worked fine.

1 Like

I am staying with 2019 for as long as I can.