Memory Palace V19 Firmware Release March 2020

Hello everyone! I’m happy to release a new version of the Memory Palace firmware today.

You can download the firmware update package here:

If you are updating from V18 or V19 beta
You will see a prompt after upgrade that requests you format internal memory by pressing yellow+orange buttons. This is normal, proceed with the instructional prompts. Fully power off your system and then restart it if you see the prompt more than once or have trouble booting into V19.


During Update-Process, I was asked for the memory format then I was shutting down the power. After restart, there comes now always the same Syslog screen where I should format and then power on/off. What should I do now?

Try powering off several times at that point. Meaning hold the buttons as instructed and power off one time. Then, when it asks you to hold the buttons and do it again, DON’T hold the buttons and simply reboot.

1 Like

It works now. Thank you


Really nice work on the menu. The way MP works is easier to understand now and the new features broaden its capabilities quite a bit. It will take a while to explore all this!

The menu refresh rate - can that be improved or is it already as fast as it will ever be?


I will be able to improve the menu refresh substantially on V20. It got de-prioritized for V19 due to time limits. Now is the time to put in your suggestions, thoughts, and feature requests!!


I’ll be spending some good time with it soon as i’m almost done with scrawl update!
will report back for sure

1 Like

I’d like to see more options with tiling, namely the ability to set them up in triangular, pentagonal or hexagonal patterns. Also capability to warp tiled patterns into 3d-ish perspective with a horizon line. Then, using all the existing capabilities with mirroring, one could make rooms and tunnels with visually active walls, for example. Additionally, like the tiles, I think mirroring could go into new territories beyond quadrants. Dreaming big here but if you could then fold the patterns into 3d shapes, that would be insanely cool.

This video shows how simple in theory patterns can be distorted into realistic perspective just by moving a few points where lines intersect.


so I am having some problems uploading this new firmware. I currently have v.18 and want to upgrade to the new one.

my screen is now stuck on this SYSLOG page where it keeps telling me to press the Yellow + orange buttons and then power it back on. After I do that it keeps loading the same page.
The screen says:

UI Init OK
SD Card OK
ERROR: Could Not access internal memory Press yellow + Orange buttons to reformat.

Do I have to hold the 2 buttons down the whole time when it tells me and turn it off?

Or do I just simply press the 2 buttons, let go and then reboot?

Ive done the same prompt may 90 times and it keeps taking me to the same screen.

Im sure all these power ups and downs isn’t good for the modules?

So far it seems my Memory Palace is bricked.

Any help would be great!


I ran into this too after having to pull SD card and loading files directly from PC. In hindsight, I should have just tried booting from SD without pulling. Seemed like the SD cage thing was glued down and ended up popping off while trying to flip it up. Or I’m just a doofus :smiley:

I tried following prompt a couple times to end up stuck in SYSLOG screen loop. As mentioned above, try power cycling without doing format. Worked on mine at least. Hope this helps!

1 Like

ill tried turning it on and off without pressing the 2 buttons and see if that works and it still stuck on SYSLOG.

is there a way to just revert back to Version 18? or am i just screwed

Any chance to decrease the fan speed on the module in V20??? I noticed it’s extremely loud in a studio setting. Maybe it’s possible to mod the fan or install a larger one?


You tried removing the micro sd card, formatting and copied the files over? Next step would be with the power off Hold down the “BOOT FROM SD” button located on the rear and power on.

i just tried the method you describes now my Memory Palace turns on with a Black screen and nothing pops up.

This is turning into a big mess . i just want to go back to Version .18 Where it was working .

Damn, sorry that didn’t help.

Please note that I’m only guessing and definitely don’t want to give you anymore advice that doesnt work!!

I would think that you could still rollback to v18 The user guide on here has instructions on updating firmware when it doesnt boot. Memory Palace User Guide I found removing the SD quite unpleasant so hopefully you don’t end up having to do that.

I finally got it back to version 18. I will most likely stick with this one. Trying to update to this new one has given me nothing but troubles.


Glad you were able to get it running at least!

Im liking the updated UI for v19 and extra features look promising but will most likely roll back to v18. Tile mode glitches out and I use quite frequently. Was really hoping there would be a way to get rid of or adjust the size of border that Tile mode puts around Vidiot image. Which is strange because there is no border when tiling internal images. Entirely possible I’m just oblivious to a way to do this already :smiley:

this was solved simply for me by pressing the two buttons and allowing it to restart

then just power down (when it tells you to press the buttons again) like normal and back on


If you are using a Mac you might want to run the sd card through “clean my drive 2” before loading the new firmware to it. Pretty sure that was what helped get it running for me.

1 Like

i’d just like to reiterate my request for triggering stills with cv or a slideshow mode for stills