Mac Laptop into Visual Cortex

videosignal
visualcortex
externalvideo
converter
#1

What device do I need to convert the HDMI out from my Mac laptop to 480i, so I can send it to the Visual Cortex?
Thanks.

2 Likes

Visual Cortex output to a projector
#2

The upcoming TBC2 module

0 Likes

#3

Any idea when?

Thanks.

0 Likes

#4

They are supposed to ship in October. Check out the LZX website for more specific details on the Orion releases.

0 Likes

#5

You can also try an downscaler … I have purchased a couple of cheap downscaler and none of them seem to work… so I got one of these as recommended by some users of the LZX community forum.

http://shop.jmc.se/jmc-artiklar/jmc-sdihdmi-2-dvianalog-scaling.html

and works perfectly… the key is that your scaler can be configured to 576i/480i depending if you are PAL/NTSC, otherwise you will get monochrome video input.

2 Likes

#6

You could use a Blackmagic Intensity to grab the output of laptop and send into the Visual Cortex.

I also have a cheap HDMI to Component box i grabbed off Amazon that works fine.

0 Likes

#7

any recommendations for vga and/or usb-c to YPbPr?

0 Likes

#8

I use an intensity shuttle TB2 with the usb-c/TB3 outputs of my current MBP. Very reliable. Take the Mac TB3->TB2 into Intensity Shuttle very well

0 Likes

#9

thanks for the answer @a_digital_index!!

am I right in thinking that they work perfectly with syphon via black syphon?

and am I also right in thinking that if you use the input then the outputs are throughs?

so you can’t do:

component in from lzx -> intensity shuttle -> black syphon -> lumen -> black syphon -> intensity shuttle -> component out to lzx

0 Likes

#10

I don’t think the Intensity passes the signal as a thru so that set up wpild work.

You would need 2 x Intensity for that workflow.

1 Like

#11

I’m pretty sure the other post is correct. That the Intensity Shuttle cannot do output and input at the same time. That would require some heavy transcoding in two directions. But I’m not sure. It isn’t part of my workflow.

I don’t use Syphon. Let me lay out my output workflow and hopefully it will help.

Devices (In order of signal flow)
1.MacBookPro (2016) Running 10.12.6 (Sierra)
2.Black Magic Intensity Shuttle Thunderbolt. (there is a Apple TB3 to TB2 dongle between this and laptop)
3.A Bunch a LZX Gear

So the MBP is running Final Cut Pro 7. It’s old software but what I am most comfortable with. Final Cut sees the Intensity shuttle as an external video device. In external device settings I tell Final Cut what to output to the Intensity shuttle. In this case I am feeding 1080i, 59.94, 10 bit. This setting is really about the codec of the footage and the editing timebase (in this case FCP 7).

So the 1080i, 59.94, 10 bit footage runs into the Intensity shuttle. The software for the Intensity Shuttle is “Desktop Video Setup.” I’m running 10.9.7. The setting I use for this is under the Conversions tab, select HD to SD in the output conversions section. I let it letterbox because most of my footage is widescreen.

In this setup, understand that the Intensity Shuttle is doing the conversion to SD. That’s not exactly a through. THE MBP and FCP are not doing any hard work here. There may be other methods but this works for me. So, if Syphon can see external monitors you should be able to replicate the following workflow to get video out from your MBP.

I hope this helps. Let me know if you have further questions.

Chris

3 Likes

#12

Hello, I just purchased an HD video converter like the one you posted. I’m currently connecting: imac > display port > hdmi > hd video converter > ypbpr input to Cortex. The result I’m getting is a slight flashing display of what could be my video play from my imac. What are the display settings you set for your converter on your mac to be able to get a solid video display into Cortex?

Thank you for your insight.

0 Likes

#13

Set your converter to convert output timing to NTSC/480i or PAL/576i output mode. It sounds like it’s probably on an HD setting at the moment.

1 Like

#14

OK so I just got my Visual Cortex home and racked and switched on and I have a similar issue - I have a similar device to the above portta hdmi->component converter - it just has vga out as well

I have a late 2016 macbook pro 13" - so usb-c only

I am using an amazon basics usbc -> hdmi converter - I can possibly borrow a different one tomorrow evening from someone at work - but it’s not an apple one either - startech perhaps

converter works on all 3 possible settings from hdmi to component in on tv

plug component in on all 3 possible settings to VC and synch light is red/flashing - so sees picture but can’t synch

possible settings are 1080i, 1080p and 720p

I’ve tried rebooting the box after changing the settings on the mac but no luck with that either so far - maybe I have to wait a little longer before rebooting

@destroythings what settings are you using - I can’t imagine that there’s much difference in the 2 devices

0 Likes

#15

argh - I just compared the amazon ads for the 2 - problem is with the adapter

the hdmi->component and vga (which I have says supports up to 1080p
the hdmi->component adapter specifically states 480 and 576 as well - bugger - looks like I need to get the other one - oh well a few more days of waiting won’t hurt I guess

0 Likes

#16

Ok so I re read the full specs for the converter I have and it can support:

Interlaced Resolutions(50&60Hz):480i,576i,1080i
Progressive Resolutions(50&60Hz):480p,576p,720p,1080p

and I worked out how to see the other settings for resolution (hold alt when selecting scaled

I see 1080p, 1080i, 720p, 480p, 1024 * 576, 800 * 600 and 640 * 480 options but no 576i or p - which I was suspecting would be the one to use given PAL - which I’d set the cortex to

currently none of the above are working solid red light on all available options - including after quick reboot of the converter

will try changing the pal/ntsc setting on the cortex tomorrow evening and try again!!!

UPDATE

quick update I now have something approaching lock

the lock light is mostly green with steady flashes of red might be about once every 50/60Hz cycle

I have a picture being output to the screen

but it’s like there are 2 copies side by side with a stripe down the middle

any ideas anyone???

2nd update:
I’ve pretty much tried everything - the best I seem to get is the picture output side by side with a vertical bar separating them - this is currently scrolling from side to side too

my current best guess is that it’s a combination of things

cheap amazon usbc -> hdmi converter - which only allows options for NTSC (480i) and not PAL (576i) in preferences going into a cheap hdmi -> component converter - which somehow is causing the vc not to lock to the signal from the computer -> I will try to borrow a hdmi adapter from someone at work
BUT
I’ve just tested the component cable from that was in the output of the cortex and moved it to the output of the converter - that is working perfectly at 480i

I’ll try swapping the cables about a bit just in case and report back - but so far all cables were brand new

swapping the cables did not make any difference

further update

OK so to cut a long story short it appears that a lot of apple products post 2012 do not support 480i/576i output via hdmi

however I have now after much searching found this

which specifically states it converts hdmi to 480i/576i and is less than 20€ delivered

it’s arriving sometime next week (allegedly the 27th, but it’s xmas so I expect a delay)

fingers crossed that this works - if so I will be very happy - I will be able to process camera feedback through both lumen and then the modular - without shelling out another 300€+ on an intensity shuttle tb & tb2->tb3 converter & tb2 cable!

UPDATE: the above box works perfectly, but for composite, not component - so black and white only - I am seeing similar boxes for hdmi -> component with scaling for about 40€ - so one of those will be next

0 Likes

#17

Hi… I’m new here, new also into video synthesis, though I had been playing with Lumen before. Now I got a Visual Cortex and Bridge, to start experimenting with my eurorack system.

Reading some comments around, I was worried I might have problems getting video from my laptop into Visual Cortex, but it seems I’ve been lucky with a Musou Mini HDMI to CVBS converter.

I have a MacBook Pro 2016 running Sierra and I’m using a Letscom LC-USBC001-SL to get HDMI out of USB-C. I have no problems with sync (at the moment using NTSC, just because yesterday I was using an old XBOX 360 to play some NTSC videos into the Visual Cortex). The only issue seems to be that the colours are not the same. When connecting to a TV they are fine, so it’s not a problem with the converter. But, also, the signal in Visual Cortex is definitively not just black and white. It has some colours, with the Mix and Colorize turned off. They re probably better with YPbPr. Anyway, since one of my purposes is to use the Visual Cortex to colorise material, it doesn’t bother me for now.

1 Like

#18

Hi @JohnWynberg ! You hit the nail on the head in your last paragraph, you need to use YPbPr into the Visual Cortex’s decoder for color video. A composite signal to the Y input will only provide luma data.

0 Likes

#19

Hi… Thanks for the prompt reply. What confuses me is that some colours do seem correct… like the Tags from one of the Finder windows in my Mac. It’s that just an effect of the Luma when split into the RGB? I don’t think I’m colorising them yet.

1 Like

#20

@JohnWynberg That’s pretty interesting, especially if all the colors you see look correct and multiple colors are showing through. Not sure what’s up. Is it possible you have Spectrum mode on?

1 Like