LZX Cyclops 101 (or link to manual?)

Can anyone explain a barebones patch to get anything displayed using Cyclops? Having a humbling moment fumbling with this tech and would rather proceed with caution than wildly experiment. Don’t want to burn anything out… motors, eyes, etc.

Patch:

  • Visual Cortex H sync → VWG1 sync
  • VWG1 knobs at 12’ except freq range selector a notch down from 3’
  • Visual Cortex V sync → VWG2 sync
  • VWG2 knobs at 12’ except freq range selector a notch up from 3’

Just for sanity sake, I ran the pulse outputs of VWGs back into VC to be sure I’ve got the expected stable checkers.

  • VWG 1 sine → Cyclops X VC
  • VWG 2 sine → Cyclops Y VC
  • Cyclops → Laserworld DS1800RGB

Cyclops settings I’m honestly clueless on… couldn’t find the manual online. On the back are set to 1v and protection on. Front I stole settings from the rack setup photo @Dewb uploaded (Cyclops on the right w/ switches up, scale maxed, colors off from center X VC slightly left, Y VC slightly right).

If I turn the fine tune control of the VWG 2 (y) the laser will make a clicking sound at the same point regardless of if I’m sweeping left or right. Not sure if that’s a motor kicking on/off or what. To me it indicates I’m at least getting ILDA control into the laser even if my settings are out of range.

Then again, I could be doing something dumb on the laser itself. Less specific to this forum but maybe someone has a clue. The DS1800RGB manual states:

ILDA control:
Connect your device („ILDA IN“) via an ILDA cable to an interface / controller. ILDA mode starts immediately. Use a laser control software, e.g. Laserworld Showeditor, to run the device. Use „ILDA OUT“ to connect it to another device.

When the laser boots it is in the last used mode, I’ve tried Auoo and Auto as a starting point. Having the ILDA cable plugged in on boot prevents the animations from playing (both those modes go through some animation patterns) but the LCD doesn’t change from the previous mode message. Same behavior if I plug the ILDA cable in when the laser is already powered up.

If there’s already a some docs/threads out there links are appreciated! I searched but did not find & I don’t see any documentation for Cyclops in the official github repo.

It’s a lot easier to get started with Cyclops with audio rate waveforms. Try putting a 30Hz ramp wave in X and an audio source into Y, turn the sizes down small, and see what you get.

I wouldn’t take too much advice from the positions in that photo because I have A*B+C scalers in front of X and Y and I was probably doing something at the extreme edge of the projector’s range.

Hey Dewb :smiley:

30Hz ramp, can that be achieved with VWG scale set to the bottom (black box) and fine frequency adjustment at the top? Since I can see blinking via VC at that setting I assume I’m just above 30Hz at that point (referencing the Using audio modules thread). Then plug the ramp from VWG into X VC, portable audio player into Y… still nothing :face_with_thermometer:

“sizes down small” are you refering to the X / Master scale / Y knobs across the top of Cyclops? I had them set ~9 o’clock.

With Red/Green/Blue at 12 o’clock should I be getting color out? I feel like even if I’m not successfully moving anything, I should at least see a dot on the wall if colors are turned up? And I did try sweeping those knobs.

I could try switching the voltages to 5v instead of 1v and put voltage bridge between my VWG and Cyclops. Looking at your system again it looks all audio voltage so you must be running with the back switches set to 5v? My question is if the behavior changes when switching from that to 1v. Up is labeled 1V (ALL) and down is labeled +/5V (X/Y), 5V(RGB). Means switch up .5V = switch down 0V? This sounds obvious but I’ve been wrong about other basic things before :drooling_face:

When trouble shooting I tend to go less gear, not more. Along those lines in my original set up I probably didn’t need to h/v sync the oscilators since that’s just to get a steady video signal… the osc should be fine running at any rate as long as it’s in the right frequency range.

Thanks for the help!

You’re never going to see “a dot on the wall.” Your laser should have a safety feature called “scan fail” that will deactivate the diodes if the beam isn’t moving. This is so you don’t pump too much energy into something and set it on fire.

The clicking you’re hearing could be this protection kicking in, which might be a sign that you’re correctly sending signal to the laser, you just need to increase the motion you’re sending so the beam isn’t stopped. Try slowly increasing the X/Y/master scale controls. 1V and 5V shouldn’t behave any differently as long as you’re sending full range signals in whatever scale you’ve selected.

An even simpler test patch: put a 1Hz ramp into X and nothing into Y. You should be able to get a horizontal line out of that.