Escher Sketch not syncing

my Escher Sketch does not sync. it passes sync through just fine but regardless of the setup i get ripples and wrinkles in-frame when working with the Sketch. i’ve tried a few sync setups - direct sync from Visual Cortex rear sync jack, sync via the RCA jack on my Vessel, sync from another module daisy-chained to Visual Cortex and even RCA sync via Cadet I. i’ve also tried it at the end of the chain (in addition to its current location in the middle of my chain) both with and without termination on. no dice - still get the rippling tear in the screen. not sure if i somehow missed a firmware update or have a bad unit so i figured i’d check here first. any advice?

can you post some pictures of the ripples you mentioned? how are you patching it?

patching X into VC of a Bridge fader and Y into one input of the left half of Arch respectively. Diver H+V and H-V into A & B of fader. that said, i tried it in a bunch of different contexts and the ripples/tears appear regardless of how it’s used. i’ll see if i can grab a video.

hmm… diver definitely has its own ripples. maybe try crossfading h+v from cortex or an even more simple mix on bridge, just to rule out diver being an issue.

yeah i am aware of the Diver ripples - this is not those. these are distinct vertically-traveling ripples that span the width of the screen and occur with Escher no matter how i have it patched. when i discovered them i first tried Escher directly into Visual Cortex RGB inputs, no fancy patching whatsoever. still got the ripples. video incoming shortly, gotta set stuff up cuz my phone doesn’t really capture it very well.

ok here’s a clip showing the ripples. you can see horizontal lines scrolling vertically through the frame. looks just like any other clip when it isn’t syncing vertically. right now my sync chain is Visual Cortex → War of the Ants → Navigator → RCA jacks on Vessel → Escher Sketch → Diver with only Escher Sketch shown in the clip w/X and Y outs patched directly to Visual Cortex R and G inputs.

oh i see, I swear I’ve seen discussion of this before.

there’s another thread here:

and another here:

and i already took a look thru both with no resolution (in fact i didn’t even realize Escher had a sync input until i noticed the sync jacks while rearranging my rig earlier today as i’ve previously only used it with audio modules). i am beginning to think the sync circuit on mine is faulty but wanted to comb the brains of the community before contacting LZX as i know they have their hands overfull right now trying to get TBC2 and Chromagnon finished up. thanks for the input so far - hopefully someone else will chime in and tell me i’m making a dumb and obvious mistake but if not i’ll just wait for the chaos to die down and send it in for repairs.

yeah I checked the lzx docs for firmware updates, of which there are none… but did see lars mention the function of sync for escher sketch being to provide v sync which looks like is the issue on your unit. i think contact lzx and they may be able to diagnose or repair.

That’s a weird issue. Send an email to I’m sure we can sort it out.

1 Like