Visual Cortex Not Sync Locking to Converter Box

Hi there,

I just got this HDMI to component converter box (, which was recommended in another thread here (HDMI to YPbPr converter? S-Video to YPbPr connector?). However, I’m having issues setting it up properly.

My signal chain starts with a Raspberry Pi, which is connected to the HDMI in of the converter box, then I have the component outs of the converter connected to the component ins of my Visual Cortex, and finally one of the Visual Cortex’s composite outs is connected to my CRT tv. I’ve then pressed the resolution button on my converter box until I get something recognizable as my RasPi’s desktop. Let me know if you could use any extra info about any of this.

The problem I’m having is that best image I can get on the tv is slanted to the right, the horizontal lines don’t all line up like they should, and the over all image moves side to side unpredictably. I’ve noticed that the sync lock LED on my Visual Cortex blinks between red and green, so I’m guessing what’s going on is that the Visual Cortex syncs with the converter box for a second then unsyncs, hence the tv image being recognizable as my RasPi desktop but also very glitchy.

All of this happens with the Visual Cortex set to NTSC mode. I’ve tried switching it to PAL mode and the image I got was pure static on all of the converter box’s resolution settings, so no go there.

Anyways, is there anything else I should can try to get everything set up properly? And if not, should I conclude that the converter box is broken and return it for a new one, or should I conclude that it’s working like I should and I need a completely different type of converter?

Any thoughts you can share would be a huge help. Thanks!

Have you tried it with any other HDMI devices? First thing is to isolate if the issue is coming from the converter or the source.

You might also try making sure that the converter is turned on and connected to the Pi before you turn the Pi on. Also check that your Pi is outputting a resolution that the converter can understand.

If you have an HDTV with YPbPr inputs I would also try it on that to make sure the converter isn’t DOA or anything

Oh, and check your power supply and cables

1 Like

This is in the Amazon description:

5.You can press the “RESOLUTION” button 36 times. There are multiple formats for each resolution. Please be patient and choose the right resolution.

Possible you haven’t reached 480i option yet?

1 Like

Yes, I think Step #1 should be “Check that your source device is sending a signal in the right format for your VC.” In this case, that’s your Pi, and the format is set in a config file described in the Pi documentation. Even if you’ve already done this, we must check that you’ve done before we can help you with anything else.

(Also: this tip could be useful to someone else.)

Thanks so much for all the advice. It took me a couple days to get the time to test things more, but it’s still not working.

As @Genlok and @nerdware mentioned, I focused first on my input source. I stepped through all 36 resolution options on the converter box with it in between my raspi and visual cortex and couldn’t get a proper output on my tv. I changed the visual cortex from ntsc to pal and did everything again, but couldn’t get a proper output.

Then, I tried hooking my laptop to the converter because it was easier to change the resolution than on the raspi. I set the resolution to 1080p and tried a few different frame rate options, stepped through the 36 options in ntsc and pal, but still couldn’t get a clear picture on the tv.

Finally, I saw in the converter’s manual that if no video signal is connected to the input, it displays a generic colored bars image. So, I left the converter’s input unconnected and tried all 36 resolution options in ntsc and pal but still no go on the tv.

I’m assuming that should be enough to say the problem isn’t in the source. The other two options beside the converter would be the visual cortex and the tv. However, when I patch the visual cortex with the other modules I have and send the composite out to my tv the resulting image looks like I would expect it to. My video oscillator gives me vertical/horizontal lines (depending on the frequency), the ramp generator on the visual cortex gives me the various shapes/gradients, my ADC/DAC modules give me a pixelated effect, etc. I’m still very much a newb to video synthesis and LZX, but I’m assuming this is a good sign that the visual cortex and tv are working like they should because if they weren’t I’d have a similar issue with my purely-modular images right?

Like I said, I’m very much a newb to all this so please let me know if there are other things I should be trying. But right now my plan is to conclude that the problem is with the converter and send it in for a return.


1 Like

Does your TV have YPbPr? Can you test the converter on that?

Sorry about that. My tv doesn’t have YPbPr inputs, and I don’t have anything else that does.

Try using just the green output of component in to the composite input of a tv. That should at least show if the signal is stable or not?

@pbalj Thanks for the pointer! I plugged the green (Y) output of the converter into the composite in of my tv and still wasn’t getting a stable and correct image. I didn’t have anything plugged into the converter’s input, so it was outputting the generic colored vertical bars test image with a dialog box on top of it.

There were a few settings where the image on the tv was unmoving, but the image was a weird hodgepodge of horizontal and slanted lines. So the image was stable but incorrect.

And there were a few settings where the image on the tv was recognizable as the test image, but everything was slanted to the right and scrolling downwards. So it was (almost) correct but unstable.

Anyways, any advice from here? If not, does anyone know of a good, affordable HDMI to composite converter box that I can use?


I guess it is within the realm of possibility that the manufacturer has changed the specs of this device. When I had one there were only like 7 or 8 modes, and now it says 36 modes. But no 480i apparently. :shrug:

An alternative solution, which I’m currently using, is an Extron scan converter with an HDMI-VGA dongle. I have an Extron VSC-500 and an HDMI-VGA adapter from Amazon. The extra benefit of this setup is that the Extron can scale your image if it’s not 4:3 or displaying correctly otherwise.

Maybe you’re done with cheap amazon boxes but there is this, which says in the description that it supports 480i out on component

1 Like

I own that device and tried to connect a Critter & Guitari XTC, but it never worked. I just assumed I was doing something wrong. I was trying to run it back into a Visual Cortex and tried the MP as well.

@Genlok I’m looking to pick up an Extron VSC-500 from ebay. Thanks for the pointer, and I’ll let you all know how it goes!

Ok, so I finally got the VSC-500 and all the cables/adapters I’d need delivered to me. When I hooked everything up the way I figured it should go, the VSC-500 said ‘No Signal’ on its screen. (I actually ended up with 2 VSC-500s by accident, and the same happened with both of them.)

The input signal chain I’m using is (1) my laptop’s USB-C port to (2) a USB-C to HDMI passive adapter cable to (3) an HDMI to VGA passive adapter cable to (4) a VGA cable to (5) the VSC-500’s VGA/RGB input. I kept the same signal chain but connected it to a monitor I have with a VGA in instead of (5), and the monitor displayed a black screen then quickly went to sleep. So, looks like something’s up with the input chain.

Since I’ve used my laptop’s USB-C port and the USB-C to HDMI adapter cable before and never had a problem with them, I’m guessing they’re not the source of the problem. I used my multimeter and got 0-2ohm resistance readings between each pair of pins on the VGA cable, so I’m assuming that means the VGA cable isn’t the problem either. Therefore, I’m going off the assumption that the HDMI to VGA adapter is the problem.

Does my troubleshooting seem right to you all? Is that enough troubleshooting to infer correctly that the HDMI to VGA adapter is the problem? Also, since VGA is analog and HDMI is digital, will a passive cable even work to convert the two, or do I need some sort of active converter that does more than just change the physical connector?

Anyways, any help you can spare would be much appreciated. Thanks!

So, I replaced the HDMI to VGA converter and now everything looks to be working perfectly. Thanks so much the advice everyone (and @Genlok in particular)!