TBC2 - Black screen after resetting firmware

(Posting in case it can be resolved and can help someone else in the future)

I accidentally pressed ‘Reset Firmware’ on the TBC2. After it finished erasing, there was a prompt to restart - I pressed the confirm/yellow button but think it was frozen as nothing happened for a couple of minutes, so I powered down - Now, after powering back up, the TBC2 won’t show anything on the display.

I’ve tried loading the boot.bin file to an SD card and holding down the ‘Boot from SD’ button on the back of the module, but this doesn’t seem to fix it either.

Any ideas please? I’ve had about 20 minutes of usage, I am livid at my fat fingers

(Side note, for next firmware update please add a ‘ARE YOU ABSOLUTELY 100% SURE ABOUT THIS?’ before being able to erase :laughing:)

1 Like

This is the only way to reinstall the firmware. How big is the SD card and who makes it? Have you tried reformatting it?

We’ve both been struggling to source 8GB SanDisk cards in the UK.
I believe that the one that @Tundra_Tides used was a 16GB SanDisk.
I only had a 32GB SanDisk.to hand.
(Yep, I did exactly the same thing :grimacing:)

Before I picked up an extra 16GB SanDisk SD card online, I used the card from my Memory Palace. Do you have a Memory Palace handy?

1 Like

So as quick as I posted I had a brainwave and took the SD card from my Memory Palace (original that shipped with the unit) and added the boot file to it.

Repeated the same process as before (holding down boot button) and it booted with the usual screen.
I then selected ‘Update Firmware’ and followed the onscreen instructions to update and reboot.

Now it’s up running again! (have removed the SD card and after a power cycle everything seems normal again)

Issue: Dodgy SD Cards! Solved by using genuine SD Card from MemPal


You can use other cards, but we haven’t confirmed that other cards will work.

You beat me to it :slight_smile:

I’ve got a few other MicroSD (Sandisk 8GB & 16GB) which didn’t work, so I assume these are probably fakes or something.

1 Like

It is possible to use larger cards: you have to go through the hassle of partitioning the drive. I only had a 128Gb card lying around. I partitioned it to 16Gb and format. Works!


I eventually managed to use my MemPal micro SD card to reinstall the firmware on my TBC2.
BEWARE the instructions on the Memory Palace System Recovery page talk about removing the SD card from a hinged holder. My (and TundraTides’) MemPal’s were both press in to release. Those instructions need updating to prevent somebody damaging their MemPal.
I’m happy to provide a photo of my push to release MemPal if that would be helpful.