LZX website, I can't get a connection

I don’t know what is going on. I have not been able to connect to the LZX website for a long time now.

I’ve tried it with several browsers, no luck. cleared the cache. no dice.

Some help would be appreciated!

note: I’m located Italy, have a PC and run win7.
the error message = connection timed out

I tried it on another device (android tablet), same problem.

so it might have something to do with the router, but I don’t understand why

it’s ok for me
netherlands/mac/firefox

That’s annoying!
No problems here. Netherlands, Firefox, PC, Windows 10. Connection through Android phone + Chrome is also fine.

works for me too. Mac High Sierra 10.13.6 / Chrome

All’s well in Texas, using Windows 7 with Chrome or Firefox.
The site is working on my Andorid phone too.

all good on my iphone too

1 Like

if it is something with the router, what could cause this?
I don’t have this with other sites. is it a country thing?

is it since you moved or more recently??
can you try on your phone or laptop from somewhere with public wifi?
if that works then -
is the router supplied by the provider?
if so I’d be tempted to contact them - have you tried a hard reboot of the router?

I don’t have access to the router, I only have the wifi password.
I’ll check on another wifi spot if I get the chance.